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In our film Stick to Manual, the main character Benfolio uses a dry-erase marker to draw a 

picture of a tie on his chest locker. After time-consuming attempts to manually animate his 

hand following the texture (manually), I realized that using constraints would be a much faster 

way to program the motion, and more dynamic. 

By using constraints instead of key-framing the motion, we can easily make changes to the 

motion path without losing animation data. 

This technique is designed to give the animator as much flexibility as possible. I have added a 

few steps, such as additional locators, to build in the ability to turn off the hand following the 

motion path, or to turn off the object being held (in this case, his marker) following his hand. 

This way, he can draw the picture, move his hand off the motion path, drop the marker or put it 

away, and continue on his merry way. 

So, let’s get started! 

  



1) Open a new scene in Maya. 

 

2) Set project. 

-File>Set project 

-Locate folder 

-Set 

 

  



3) Check settings. 

-Click the orange running man with the gear in the lower right corner of Maya, or go to 

Windows>Settings/Preferences>Preferences 

-Click the Time Slider settings 

-Make sure the frame rate is 24 fps, and the playback is 24 fps x 1 

-It also helps to change Update View from Active to All so that your animation will play in all 

layout panels simultaneously 

-Click the Animation settings under Settings (not under Display) 

-Make sure Auto Key is on. I will be using Auto Key. If you are not using Auto Key, you will need 

to remember to press "S" when making changes to key them 

-Change Default in tangent to Flat and Default out tangent to Clamped so you are not working 

with Automatic tangents 

-Click Save and exit the settings window 

 

 



 

  



4) Reference a rig into your scene. 

-File>Create Reference>Options 

-Reset settings 

-Click Reference 

-Locate rig in folder 

-Click Reference 

 

  



5) Prepare the rig for animation. 

-Set time slider to -100 

-Select>All by Type>NURBS Curves 

 

-Press "S" to set a key on all curves at -100 

 

-Set time slider to -10 



-Press "S" to set a key on all curves at -10 

-Select the rig's All Anim control 

-Scale the rig's globalScale to what it will be used for animation: in Benfolio's case, 0.2 

 

-I often hide things like Joints in the viewport so they aren't distracting. To do this, select Show 

on the top of the viewport panel and uncheck what you don't want to see. Make sure Polygons, 

Locators, and NURBS Curves are still visible, however. 

 

  



6) Save your scene. 

-File>Save Scene As or press "ctrl+shift+S" 

-Select the folder you want 

-Rename the file how you want 

-Save As 

 

7) Create the prop. 

-Set time slider to 0 

-In this case, I will be making a marker for Benfolio to draw with. If you have a different prop, 

import it now into the scene with File>Import or reference it into the scene like we did with the 

rig 

-Create>Polygon primitives>Cylinder 

-Scale the cylinder down so it has the approximate proportions of a dry-erase marker 

-Rename the cylinder something useful, in my case markerProp 

 

  



8) Group markerProp with itself. 

-With markerProp selected, go to Edit>Group or press "ctrl+G" 

-Rename the group to something useful, in my case markerProp_group 

-Modify>Center pivot to align markerProp_group's pivot with marker_Prop's pivot 

 

8.5) Save. 

 

9) Create a curve to serve as the motion path. 

-Create>Curve Tools>EP Curve Tool 

 

-It doesn't have to be anything fancy; just something for our character to draw. You can also 

import a curve if you have a specific pattern in mind, like with Benfolio's tie 

-Once in the tool, click on the grid to create points on the curve and draw a path. It helps to use 

the Top orthographic view so you are not viewing your curve in perspective 



 

-Once you have a nice curve, Modify>Center Pivot to align its pivot with the curve 

 

-Translate, scale, and rotate the curve until it is in the position you want. In my case, I want it to 

look like Benfolio is drawing on his own chest, so I will move it in front of his locker 

-Rename the curve something useful, in my case markerCurve 



 

  



10) Freeze transformations on markerCurve. 

-Once markerCurve is in the position you want, open the Channel Box 

-Click and drag on the translate, rotate, and scale boxes so that they highlight blue 

-Right click the selection 

-Select Freeze>all 

-The values for translation and rotation should now be 0, and the values for scale should be 1 

 

 



 

11) Group markerCurve with itself like we did with markerProp. 

-Name the group something like markerCurve_group 

-Modify>Center Pivot to align markerCurve_group's pivot with markerCurve's pivot 

 

11.5) Save. 

  



12) Constrain markerCurve_group to follow the body_anim of the character rig. 

-When using parent constraints, the selection order is driver>driven, or leader>follower 

-So first select the Body Anim of the character rig, and then shift+select (or ctrl+select in the 

Outliner) markerCurve_group. The Body Anim may be named differently; for Benfolio, it is 

body_anim. It is the main control near the character's core that determines the center of 

gravity for the character and drives the rest of the torso. NOT the All Anim 

-Under the Animation menu, select Constrain>Parent>Options 

 

-Reset settings 

-Add 



 

-Now if we move the body_anim, markerCurve_group will follow. This makes it look like the 

curve is actually on Benfolio's chest 

 

-If you did move the body_anim to check, undo that change. We won't animate that yet 

  



13) Create a locator to which to constrain the wrist control. 

-Set the time slider to 0 

-Create>Locator 

 

-Name the locator something useful. I prefer to use the naming convention 

locator_objectConstraining_objectBeingConstrained_frameNumberTheConstraintHappens, so 

in this case locator_motionPath_RHand_1. When there are several locators in a scene, the 

name helps me keep track of which locator is doing what and when 

-Translate, rotate, or scale the locator into position, either in the middle of markerProp, or at 

the tip where markerProp meets markerCurve. The exact position doesn't matter as long as it 

gives you a good idea of what the hand will be doing when we constrain it 



 

13.5) Save. 

 

14) Constrain locator_motionPath_RHand1 to markerCurve as a motion path. 

-So if you were paying attention earlier, you'll remember that parent constraints should be 

selected in the order of driver>driven, or leader>follower. This is the one exception in this 

tutorial: for making a motion path from a curve like this, you must first select the object to be 

constrained and then the curve 

-So select locator_motionPath_RHand_1, and then shift+select (or ctrl+select in the Outliner) 

markerCurve 

-Under the Animation menu, select Constrain>Motion Paths>Attach to Motion Path>Options 

 



-Reset settings 

-Change Time Range from Time Slider to Start/End 

-Type in the values you want; in my case, Start time: 1 and End time: 100 

-Uncheck Follow. If you keep it checked, rotation values will be added. We only want 

translation values so that the marker tip stays perpendicular with the front of the locker 

-Select Attach and exit the options box 

 

15) Check animation. 

-Play or scrub along the timeline to check if everything is working. If it has been set up correctly, 

locator_motionPath_RHand_1 should now follow the path of markerCurve in 100 frames 

-You should also see in the viewport that markerCurve now has numbers on either end of the 

curve indicating to which frame it corresponds: 1 at the beginning of the curve, and 100 at the 

end 



 

15.5) Save. 

 

  



16) Constrain locator_motionPath_RHand1 to follow the body_anim of the character rig for 

rotations. 

-Like we did with markerCurve_group, we want locator_motionPath_RHand1 to follow 

body_anim's rotation values. However, we do not want to constrain the translation values, 

because those are being driven by markerCurve's motion path 

-Select body_anim and shift+select (or ctrl+select in the Outliner) locator_motionPath_RHand1 

-Constrain>Parent Constraint>Options 

-Uncheck Translate but keep Rotate 

-Add 

 

-Now if we rotate body_anim, locator_motionPath_RHand1 will follow 



 

-Once again, if you did move or rotate body_anim, undo that change 

 

16.5) Save. 

 

  



17) Prep the right hand to be constrained. 

-Make sure the time slider is set to 0 

-Select the IK/FK switch control for the right hand. It may be named differently; Benfolio's is 

named r_arm_settings_anim. It should be a control near the wrist but not the wrist anim, 

perhaps an arrow 

-Change the Fkik Switch value in the Channel Box from 0 to 1. Set a key if necessary 

 

18) Constrain the right hand control to a second locator. 

-Once constrained always constrained. If, later in the animation, we want to move the right 

hand independently of locator_motionPath_RHand1, we must have a separate constraint for it. 

Something that is guaranteed not to move. We can go ahead and constrain the right hand now, 

and later key the weight off this constraint while the right hand is being driven by 

locator_motionPath_RHand1 

-Create a second locator 

-Name it something useful, in my case locator_world_RHand_0 

-You can keep it at the origin, or move it somewhere else if it gets distracting 

-I have made this mistake before, and it wrecked my animation. Do NOT constrain the actual IK 

hand control, or you will be unable to animate it at all. Instead, constrain the group ABOVE the 

IK hand control in the Outliner. Just like with markerCurve_group, we will constrain groups so 

that we can still animate underneath 



 

-So, select locator_world_RHand_0, and then shift+select (or ctrl+select in the Outliner) the IK 

hand control GROUP for the right hand. Benfolio's is called r_ik_hand_anim_const 

-Constrain>Parent Constraint>Options 

-Reset settings, make sure translate is back on 

-Add 

 

18.5) Save. 



 

19) Move markerProp_group to its start position. 

-For me, it is easier to position markerProp in place and then wrap the hand around it. If you 

prefer to position the hand first and then fit markerProp inside it, then feel free to do the next 

steps in reverse order 

-We want it to look like markerProp is drawing out the pattern. To do this, we'll move it to the 

first point of the curve so that it follows the curve as a motion path 

-Make sure your time slider is still at 0 

-Translate and rotate markerProp until the tip is touching the first point of markerCurve 

-Freeze transformations on markerProp 

-Select markerProp_group and locate the pivot 

-If the pivot has moved away from markerProp or has been left behind, Modify>Center Pivot 

again to re-align it 

-Freeze transformations on markerProp_group if necessary 

 

19.5) Save. 

 

20) Position the right hand control around markerProp. 

-Select the IK hand control for the right hand-- not the FK/IK switch control from before. Yours 

may be named differently; Benfolio's is r_ik_hand_anim 

-Press "S" to set a key and make sure that auto key is registering any changes you make to the 

hand's position 

-Translate and rotate the hand control until it looks like the character is holding the marker. You 

may also want to key the fingers with the hand control. If you do so, make sure to key all of the 

controls to which you make changes. I also moved the r_ik_elbow_anim so that Benfolio's arm 

would bend 



 

21) Constrain markerProp_group to locator_world_RHand_0. 

-This will become the constraint for if we no longer want Benfolio to hold the marker (he drops 

it, puts it away, etc) 

-Select locator_world_RHand_0, and then shift+select (or ctrl+select in the Outliner) 

markerProp_group 

-Constrain>Parent>Options 

-Reset settings 

-Add 

 

21.5) Save. 

 

22) Create a third locator to bridge between the right hand control and markerProp_group. 

-I know this sounds like a lot of locators, but this will come in handy if we want to do anything 

like make Benfolio juggle the marker from hand to hand, or drop the marker and pick it back up 

again. By not constraining markerProp_group to his hand control directly, we build in flexibility 

for later 



-Create>Locator 

-Name it something useful, like locator_RHand_marker_1 

-Translate, rotate, and scale the locator into the character's hand, near where the marker and 

the hand will meet. The exact position doesn't matter, as long as you can see what's going on 

 

22.5) Save. 

 

23) Constrain locator_RHand_marker_1 to r_ik_hand_anim. 

-Select r_ik_hand_anim, and then shift+select (or ctrl+select in the Outliner) 

locator_RHand_marker_1 

-Constrain>Parent>Options 

-Reset settings 

-Add 

 

24) Constrain markerProp_group to locator_RHand_marker_1. 

-Almost there! Select locator_RHand_marker_1, and then shift+select (or ctrl+select in the 

Outliner) markerProp_group 

-Constrain>Parent?Options 



-Reset settings 

-Add 

 

25) Key the right hand constraints to follow the desired controls. 

-Okay, so here’s where we will actually key which constraints we want to be active at the start 

of the animation. Right now, we have two constraints on r_ik_hand_anim_const, and two 

constraints on markerProp_group. We don’t want them both to be active at once, however 

-Select r_ik_hand_anim_const and scroll down to the bottom of the Channel Box under Shapes, 

or select r_ik_hand_anim_const_parentConstraint1 and scroll down to the bottom of the 

Channel Box 

-The two constraints should be the two last boxes, labeled Locator World RHand 0W0 and 

Locator Marker RHand 1W1. Select both boxes and right-click 

-Select Key Selected to set a key for the values 

-Set the value for Locator World RHand 0W0 to 0 

-Set the value for Locator Marker RHand 1W1 to 1 

 

  



26) Key the markerProp_group constraints to follow the desired controls. 

-This is the same thing we just did, but with markerProp_group’s constraints instead 

-Select markerProp_group and scroll down to the bottom of the Channel Box under Shapes, or 

select markerProp_gorup_parentConstraint1 and scroll down to the bottom of the Channel Box 

-The two constraints should be the two last boxes, labeled Locator RHand Marker 1W0 and 

Locator World RHand 0W1. Select both boxes and right-click 

-Select Key Selected to set a key for the values 

-Set the value for Locator Marker RHand 1W0 to 1 

-Set the value for Locator World RHand 0W1 to 0 

 

  



27) Check animation. 

-Play or scrub through the timeline to check the animation. If all goes well, then 

markerProg_group should follow locator_RHand_marker_1, which should follow 

r_ik_hand_anim, which should follow locator_motionPath_RHand_1, which should follow 

markerCurve, and markerCurve_group should follow body_anim! And everything moves 

together! 

-Simple, right? 

 

-This is as far as I’ll go for this tutorial, but if you would want to make the character drop the 

prop, or stop following the motion path, then simply key the reverse values for the constraints 

(for the right hand, key the value of Locator World RHand 0W0 to 1 and the value of Locator 

Marker RHand 1W1 to 1, etc) and animate from there 

 

27.5) If I haven’t said it enough, save! 


