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Utilizing the Roto Node for Special Effects 

Nuke is a powerful node based compositing program used as an industry standard in both 

film and commercial environments.  One of the many useful tools the program offers is 

rotoscoping. Rotoscoping is the rotated projection of a sequence of action image frames so that 

the artist can trace from the frame or create an image to superimpose on it. Nuke allows its users 

to utilize two nodes, the Roto Node and the RotoPaint node to do this. The two nodes share many 

similarities with the main difference being that the Roto node is the optimal choice if rotoscoping 

is the only work that needs to get done. It allows you to create and edit Bezier and B-spline 

shapes. This differs from RotoPaint, which allows you to create and edit Bezier and B-spline 

shapes, as well as draw paint strokes with various brushes and gives you a broader scale of tools 

to use.  

 Stick to Manual utilizes the Roto node for some special effects to mask areas, create rays 

of light and more. In particular, the short film uses rotoscoping to create a glowing eyes effect 

and the start of a hologram technique; both of which are important to the Boss Lady’s 

appearance in the film.  

*This paper will go over how to import a 3D object into Nuke and apply textures, lighting, and a 

camera to the 3D scene. In addition, it goes over rotoscoping, volume rays, and cryptomatte’s, as 

well as a glossary of all the merge node operations.   



Using Roto Nodes to create a 3D Hologram Effect 

The Boss Lady is first introduced as a hologram existing as a portrait in the office for a 

majority in the film. In order to achieve this effect, a combination of compositing in Nuke and 

Houdini Particles was used. This tutorial will only cover the Nuke portion of the effect which 

utilizes Roto nodes to mask off areas where Volume Rays will emit beams of light.  

1. Open Nuke and go to the 3D display by clicking V on your keyboard while hovering over 

the viewport, using the dropdown shown below to select 3D view, or pressing tab in the 

viewport to switch between 2D and 3D. There are many ways to access different nodes in 

Nuke. It’s most beneficial to workflow speed to learn as many hotkeys as you can.  

2. Create a ReadGeo node. This can be found by pressing Tab in the Node Graph and typing 

“ReadGeo” or  right clicking in the Node Graph, navigating to 3D>Geometry>ReadGeo. 

Navigate to the .obj or. fbx model that you’ll be turning into a hologram.  

 



3. Using Read Nodes, import the diffuse map(s) that make up your .fbx object. If you have 

multiple diffuse maps, create a UVTile Node by pressing Tab in the Node Graph and 

typing “UVTile” or right clicking in the Node Graph, navigating to 3D>Shader>UVTile. 

In the properties panel of the UVTile node, enable the udim number by checking off the 

enable button. Input the udim number of the associated diffuse map to ensure each map 

gets placed in its proper place.  

4. Use MergeMat Nodes to merge the different diffuse maps by pressing Tab in the Node 

Graph and typing “MergeMat” or right clicking in the Node Graph, navigating to 

3D>Shader>MergeMat. If there are more than two diffuse maps, merge two of them 

together in the A and B Channels, then create another MergeMat node and merge the 

MergeMat node with the remaining diffuse map. Connect the img input from your 

ReadGeo node into the output of the MergeMat node. 

 



5. Create a Scene node by pressing Tab in the Node Graph and typing “Scene” or right 

clicking in the Node Graph, navigating to 3D>Scene.  Connect the output from your 

ReadGeo node into your Scene node. 

6. Create a Camera Node by pressing Tab in the Node Graph and typing “Camera” or right 

clicking in the Node Graph, navigating to 3D>Camera.  In the properties panel of the 

Camera node, check off the “read from file” box in the “Camera” tab. Navigating to the 

“File” tab, check off the “read from file” box. Click on the small folder icon next to the 

reload button and import the camera used by your. fbx model. To export a. fbx model 

with a camera, select both your geometry and camera in Maya, and navigate to 

File>Export Selection. Name your file, change the file type to FBX export, and click 

Export Selection. 

7. Create a ScanlineRender Node by pressing Tab in the Node Graph and typing 

“ScanlineRender” or right clicking in the Node Graph, navigating to 

3D>ScanlineRender.  Connect the output of your Camera node to the ScanlineRender 

node. Connect the output from your Scene node into the obj/scn input of the 

ScanlineRender 

 

 

 

 

 

 

 



 

 

8. Create three lights Node by pressing Tab in the Node Graph and typing “Light” or right 

clicking in the Node Graph, navigating to 3D>Lights>Light.  Create a three-point 

lighting system around your .fbx model and/or light the object in whichever way you’d 

like. Connect the outputs of your lights into your Scene node.  

 

 

 

 

 

 

 

 

  



The Finished Tree and Rendered Shot  



Using Roto Nodes to create a 3D Hologram Effect 

The Boss Lady is first introduced as a hologram existing as a portrait in the office for a 

majority in the film. In order to achieve this effect, a combination of compositing in Nuke 

and Houdini Particles was used. This tutorial will only cover the Nuke portion of the effect 

which utilizes Roto nodes to mask off areas where Volume Rays will emit beams of light.  

1. Create a Read node by pressing Tab on the keyboard and typing “Read” and pressing 

enter, or by using the “R” hotkey in the Node Graph. You can also create a new Read 

Node by navigating to the sidebar under File, clicking on the Image icon and navigating 

to “Read”. There are many ways to access different nodes in Nuke. It’s most beneficial to 

workflow speed to learn as many hotkeys as you can. 

2. Navigate to your .exr file’s beauty pass. 

3. Create a Grade node by pressing Tab on the keyboard and typing “Grade” and pressing 

enter, or right clicking in the Node Graph, navigating to Color>Grade. You can also press 

the “G” hotkey in the Node Graph. The Grade node defines white and black points by 

sampling pixels from the Viewer. You can use this node for matching foreground plates 

to background plates. 



 

4. Copy and paste the Read node and Grade node by pressing CTRL+C and pasting with 

CTRL+V. 

5. Create a Blur node by pressing Tab on the keyboard and typing “Blur” and pressing 

enter, or right clicking in the Node Graph, navigating to Filter>Blur. You can also use the 

“B” hotkey in the Node Graph. Connect the input pipe to the output of the Grade node. 

6. Create a Glow node by pressing Tab on the keyboard and typing “Glow” and pressing 

enter, or right clicking in the Node Graph, navigating to Filter>Glow. Connect the input 

pipe to the output of the Blur node.  



 

7.  Create a Merge node by pressing Tab in the Node Graph and typing “Merge” or right 

clicking in the Node Graph, navigating to Merge>Merge.  You can also use the “M” 

hotkey on your keyboard. Set your first Read and Grade node to the B pipe and the Glow 

node to the A pipe. In the properties panel of your Merge node, set the operation to under. 

The resulting image will have the glow underneath the rendered image (layers image B 

over A according to the matte of image B)  

  



Adding Houdini Particles 

The particle effect was created using Houdini Particles and a glitch effect that utilizes 

expressions. This paper will not go into detail in creating the expressions or particles as they 

were not made by me. All the Transform nodes mentioned are to adjust the positioning of the 

pre-rendered particles and glitch expressions to match the shot the hologram is being rendered 

into. You can create Transform nodes by pressing Tab in the Node Graph and typing 

“Transform” or right clicking in the Node Graph, navigating to Transform>Transform.  You can 

also use the “T” hotkey on your keyboard. It is recommended that the particles are pre-rendered 

with the proper camera angle matching the beauty .exr’s to avoid having to adjust in 

compositing. 

1. Create a Read node with the. exr of the rendered particle effect in Houdini. 

2. Create an Expression node by pressing Tab in the Node Graph and typing 

“Expression”. 

3. Create another Expression node. 

4. Create a Merge node to merge the two Expression nodes together. Set the merge 

operation to plus (The sum of image A and B). 

 

 

 

 

 



5. Copy and Paste the above Expression and Merge nodes.  

6. Create a Merge node. Set the output of the first set of expressions to the B pipe and 

the output of the second set of expressions to the A pipe. Set the merge operation to 

over (this is the default operation. layers image A over B according to the alpha of 

image A). 

 

7. Create a Multiply node by pressing Tab in the Node Graph and typing “Multiply” or 

right clicking in the Node Graph, navigating to Merge>Merges>Multiply. The 

multiply node multiplies a channel’s values by a given factor, which has the effect of 

lightening the channel while preserving the black point. This operation is also known 

as gain. Connect the input pipe to the output of the merge node. 

8. Create a Color Correct node by pressing Tab on the keyboard and typing “Color 

Correct” and pressing enter, or right clicking in the Node Graph, navigating to 

Color>Color Correct. You can also use the “C” hotkey in the Node Graph. The Color 



Correct node is used to make quick adjustments to contrast, gamma, gain, and offset. 

Connect the input pipe to the output of the Multiply node. 

9. Create a Merge node. Set the output of the second glitch effect to the B pipe and the 

output of the particle read node to the A pipe. Set the merge operation to divide 

(divides the values but stops two negative values from becoming a positive number). 

 

10. Create an Expression node. 

11. Create a Blur node. Connect the input pipe to the output of the Expression node. 

12. Create a Clamp node by pressing Tab in the Node Graph and typing “Clamp” or right 

clicking in the Node Graph, navigating to Color>Clamp. The Clamp node constrains 

values in the selected channels to a specified range. Connect the input pipe to the 

output of the Blur node. 



 

13. Create a Multiply node. Connect the input pipe to the output of the Clamp node. 

14. Create a Color Correct node. Connect the input pipe to the output of the Multiply 

node. 

15. Create a Merge node. Set the output of the second glitch effect to the B pipe and the 

output of the first set of the glitch effect to the A pipe. Set the merge operation to 

divide. 

 

 

 

 

 



16. Create a Noise node by pressing Tab in the Node Graph and typing “Noise” or right 

clicking in the Node Graph, navigating to Draw>Noise.  

17. Create an Expression node. Connect the mask input put of the Expression node to the 

output of the Noise node.  

 

 

 

 

 

 

 

18. Create a Blur node. Connect the input pipe to the output of the Expression node. 

19. Create a Glow node. Connect the input pipe to the output of the Blur node.  

20. Create a Multiply node. Connect the input pipe to the output of the Glow node. 

 

 

 

 

21. Create a Color Correct node. Connect the input pipe to the output of the Multiply 

node. 



22. Create a Merge node. Set the output of the third set of expressions to the A pipe and 

the output of the first and second set of expressions to the B pipe. Set the merge 

operation to over. 

23. Create another Merge node. Set the output of the particles to the A pipe and the 

output of the Hologram object to the B pipe. Set the merge operation to over. 

 

 

  



Creating Volume Rays 

1. Create a Roto node by pressing Tab on the keyboard and typing “Roto” and pressing 

enter, or by using the “O” hotkey in the Node Graph. On the side bar, create an 

Eclipse Curve.  

2. Create a Grade node. Attach the output of the Roto node into the input of the Grade 

node.  

 

3. Create Volume Rays by pressing Tab on the keyboard and typing “Volume Rays” and 

pressing enter. Attached the img pipe to the output of the Grade node.  

4. Create a Blur node. 



 

5. Create a Roto node and create an Eclipse curve. 

6. Create a Grade Node. 

 

 

 

 

 

 

 

 

 

 

 

 



7. Create a Volume Ray node. Connect the img pipe to the output of the Grade node. 

8. Create a Color Correct node. Connect the output of the Volume Ray node to the input 

of the Color Correct node. 

9. Create a Merge node and set the output of the Blur node to pipe A and the output of 

the Color Correct node to pipe B.  

 

10. Create a Cryptomatte node by pressing Tab on the keyboard and typing 

“Cryptomatte”. This paper covers Cryptomatte usage at a surface level later on. 

Tanice Arnold’s paper goes into further detail on how to utilize Cryptomatte’s to their 

full potential.  

11. Create a Grade node. 



 

12. Create a Volume Rays node. 

13. Create another Volume Rays node. 

14. Merge the two Volume Ray nodes together. 

 

15. Create a Blur node. 



16. Create a Noise node by pressing Tab on the keyboard and typing “Noise” and 

pressing enter, or by using the “N” hotkey in the Node Graph. 

17. Create a Merge node and set the operation to over. Merge the third set of Volume 

Rays with the merged output of the first and second set. 

 

18. Create another Merge node and merge the three sets of Volume Rays with the 

hologram with particles. Set the Volume Rays to pipe A and the Hologram with 

particles to pipe B. Set the merge operation to over. 

 

  



Finished Node Tree 

 

  



Merging Hologram to Rendered Environment 

 

1. Create a Read node with the. exr of the rendered environment. 

2. Create a Glow node. 

3. Create a Roto node and roto around the area that needs to be masked out. Set the roto 

to Mask. Connect the output of the Glow node to the input of the bg pipe in the Roto 

node. 

 

 

 

 

 

 



4. Create a Merge node and set the operation to over. Click the box next to the word 

mask and select mask.a from the drop down. You may find it in the other channels 

drop down. Merge the output from the hologram effect with the output of the Read 

node of the rendered environment.  

5. Create a ZDefocus node for added depth and dimension in the environment. This 

paper does not cover ZDepth in detail, it is an additional render pass that you can add 

to your film to bring more realism to your shots. 

 

6. Create a Read node of the rendered environment. 

7. Create a Reade node of the Cryptomatte pass of the rendered environment.  

8. Cryptomatte out the object that will need to be in front of the hologram. Since Boss 

Lady is a Hologram on the wall, Benfolio is constantly passing in front of her. Rather 

than rotoscoping Benfolio out, Cryptomattes allow for quick automatic masking.  



 

9. Merge the rendered environment beauty pass with the Cryptomatte output.  

10. Create a Merge node. Connect the output of the Merge node’s mask pipe with the 

Cryptomatte. Set the output to the merged beauty and Cryptomatte to input pipe A, 

and the output of the ZDefocus node to input pipe B. Set the Merge operation to over.  

 



Lastly, a Glow effect was added to Benfolio’s eyes by using Cryptomatte’s for his face geometry 

and adding a Glow and Blur node. This paper will not cover how to do so in greater detail than 

what is stated above, see Christian Antonini’s paper for more information. Merge the Glow 

effect with the output of the finished hologram effect composited into the environment.  

  



Finished Node Tree and Rendered Shot 

 

 

  



Merge Node Operations Glossary 

Atop-Shows the shape of image B, with A covering B where the images overlap. 

Average-The average of the two images. The result is darker than the original images. 

Color burn-Image B gets darker based on the luminance of A. 

Color dodge-Image B gets brighter based on the luminance of A. 

Conjoint over-Similar to the over operation, except that if a pixel is partially covered by both A 

and B, conjoint-over assumes A completely hides B. For instance, two polygons where A and B 

share some edges but A completely overlaps B. Normal over produces a slightly transparent 

seam here. 

Copy-Only shows image A. 

Difference-How much the pixels differ. Also available from Merge > Merges > Absminus. 

Disjoint over-Similar to the over operation, except that if a pixel is partially covered by both a 

and b, disjoint-over assumes the two objects do not overlap. For instance, two polygons that 

touch and share an edge. Normal over produces a slightly transparent seam here. 

Divide-Divides the values but stops two negative values from becoming a positive number. 

Exclusion-A more photographic form of difference. 

From-Image A is subtracted from B. 

Geometric-Another way of averaging two images. 

Hard light-Image B is lit up by a very bright and sharp light in the shape of image A. 

Hypot (Previously Diagonal)-Resembles the plus and screen operations. The result is not as 

bright as plus, but brighter than screen.Hypot works with values above 1. 

In-Only shows the areas of image A that overlap with the alpha of B. Also available from Merge 

> Merges > In. 

Mask-This is the reverse of the in operation. Only shows the areas of image B that overlap with 

the alpha of A. 

Matte-Premultiplied over. Use unpremultiplied images with this operation. Also available from 

Merge > Merges > Matte. 

Max-Takes the maximum values of both images. Also available from Merge > Merges > Max. 

Min-Takes the minimum values of both images. Also available from Merge > Merges > Min. 

Minus-Image B is subtracted from A. 

Multiply-Multiplies the values but stops two negative values from becoming a positive number. 

Also available from Merge > Merges > Multiply. 

Out-Only shows the areas of image A that do not overlap with the alpha of B. Also available 

from Merge > Merges > Out. 



Over-This is the default operation. Layers image A over B according to the alpha of image A. 

Overlay-Image A brightens image B. 

Plus-The sum of image A and B. Also available from Merge > Merges > Plus. Note that the plus 

algorithm may result in pixel values higher than 1.0. 

Screen-If A or B is less than or equal to 1 the screen else use the maximum example, resembles 

Plus. Also available from Merge > Merges > Screen. 

Soft light-Image B gets lit up. Not as extreme as the hard-light operation. 

Stencil-This is the reverse of the out operation. Only shows the areas of image B that do not 

overlap with the alpha of A. 

Under-This is the reverse of the over operation. Layers image B over A according to the matte of 

image B. 

Xor-Shows both image A and B where the images do not overlap. 

 


