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SYNOPSIS OF TECHNICAL PAPER

This paper will address and explore two topics under the umbrella of “How to create 
an nCloth blanket”:

Part 1:

How to create a high-poly nCloth with an actual thickness to the model (not just a 2D 
plane) and allow it to be animated like an nCloth easily

Part 2:

How to add a normal map to create the illusion of depth on a high-poly model to 
give it added complexity



PART 1: CREATING A THICK, HIGH 
POLY, NCLOTH BLANKET 

Creating an nCloth is generally done with a flat, 2D Plane that is then turned into an 
nCloth. This works well enough if you want to make sheets, etc. But if you want to 
make a fabric with actual depth and thickness, such as a blanket, this task gets a bit 
more technical and much harder.

Below is an example of turning a 2D plane and turning it into an nCloth and dropping 
it over some cones. It deforms and takes shape well.



THE DILEMMA OF HIGH-POLY 
NCLOTHS

Why is this harder with a more complex object, such 
as a thick, high-poly blanket? Well, take the example 
below, if the blanket with thickness is turned into an 
nCloth and dropped over these cones, the vertices 
will inner-penetrate one another, creating an issue 
for animation as well as rendering.



INTRODUCING THE WRAP 
DEFORMER

So how do we get 
around this dilemma?

We will use something 
called the 

“Wrap Deformer.”



THE WRAP DEFORMER DEFINED

What is a Wrap Deformer?

A nurbs or polygonal object used by a wrap deformation to influence another 
object (such as a nurbs or polygonal object) that controls, influences, and 
ultimately deforms that object. The deformed object will mimick the shape or 
transformations on the wrapped object.

As Autodesk Maya states in its explanation of the Wrap Deformer: 

“When you create a wrap influence object, Maya makes a copy of the 
influence object and uses it as a base shape for the deformation. Any difference 
in position, orientation, or shape between the base shape and the wrap 
influence object results in a deformation of the surface being influenced by the 
wrap deformer.”



EXPLANATION OF PROCESS

Sound fun? I think so! Lets 
see an example! 

A brief explanation of how this wrap deformer will be used to make sure that the vertices of a 
thick blanket do not penetrate each other is as follows:

1. We will create a flat 2D plane in the relative shape of a more complex 3D Blanket
2. We will make the 2D plane an nCloth
3. We will create the wrap deformer and use it to drive the complex 3D blanket so that the 

blanket is not an nCloth, but following and shaping DEPENDING on the nCloth deformer 



CREATING YOUR OBJECTS: 
2D PLANE

We want to first create a 2D Plane (In 
the Modeling Menu, go to 
Create>Polygon Primitives>Plane).

After the plane is made, You need to 
form it to look like the plane you want 
it to (since we will use this 2D plane to 
create the blanket model). 



CREATING YOUR OBJECTS: 
2D BLANKETThere are two options on how to do this: 

1) Take the planes vertices and move 
them to your desired place and 
then bump up subdivisions for both 
width and height to 50 (Found in the 
channel box under “polyPlane1”).    

2) Bump up subdivisions for 
both width and height to 
50 right away and then use 
a lattice deformer to give it 
the desired shape.

OR



CREATING YOUR OBJECTS: 
2D BLANKET

Either way you decide is up to you. The point is to create the 2D blanket that you desire 
BEFORE moving forward (Also note that if you deform with the lattice to delete history 
afterward).

The reason we are bumping up the 
subdivision height and width is due to the 
fact that nCloth calculations work better 
when the cloth has more vertice points to 
work with. It will give it a smoother as well as 
deformers need more vertice points to 
deform correctly.

This is my end blanket look: NOTE



CREATING YOUR OBJECTS: 
3D BLANKET

Moving on to the 3D blanket, we 
want to select our 2D blanket and 
duplicate it (Ctrl+D). 

Once Duplicated, grab the duplicate 
model (as this is what we will create 
the 3D blanket from. 

Left Click and select “Faces” with 
your mouse and then select all the 
faces of the blanket.

Up in the Toolbox area, select the 
figure that looks like a rectangle 
popping out of the ground (This is a 
shortcut to Extrude the model).



CREATING YOUR OBJECTS: 
3D BLANKET

Once Extruded, your controller will 
get these handles to work with to 
transform and move the faces, etc. 

Give it the thickness you want this 
way.

The above is my 3D model blanket with thickness.



CREATING YOUR OBJECTS

My two blankets 
side by side for 

comparison



APPLYING NCLOTH

The next step is to apply the nCloth to the 2D plane and make sure that it works properly.

We start by importing your 2D and 3D 
plane into the scene/shot you would 
like it to be in.

Make sure the 2D Blanket is located inside 
the 3D Blanket (transformations match). 
Then delete history on both objects 
(Edit>Delete by Type > History) and then to 
Freeze Transformations (Modify>Freeze 
Transformations).

NOTE



APPLYING NCLOTH

Select the 3D Blanket and hide it from the 
scene (Ctrl + H).

You then want to select the 2DPlane and 
select the FX Menu Set and go to 
nCloth>Create nCloth.

Then grab whatever the blanket needs to 
collide with, and in the FX Menu, go to 
nCloth>Create Passive Collider. 

This ensures that your blanket will not go 
through objects but will collide with them.



APPLYING NCLOTH
This is what your scene should look like if 
you applied the ncloth and passive 
colliders right:

There should appear yellow crosshairs with 
a circle around them to depict everything 
that is going to collide with the nCloth.

You can also check to see if your passive 
colliders and nCloths are working based on 
your Outliner (which can be found by going 
to Windows>Outliner). You should be seeing 
an “nCloth1” node as well as an “nRigid1” 
node (and possibly more” to depict your 
colliders and nCloths in your scene.

NOTE

Your 2D blanket should also 
glow purple showing that 
there is an nCloth in the scene.



APPLYING NCLOTH

The next step is to go to the 
timeline, right click and hold and 
choose playback speed>Play 
Every Frame, Free

1

Then in the box 
below and to the 

right of the timeline, 
change the timeline 
to go for 300 frames 

(this gives the 
object/nCloth some 

time to collide 
underneath.

The final text is to let it play and make 
sure it does, in fact collide with the 
designated object. 

When this is 
done, rewind 
the timeline 
to frame 1.

2
3

4



APPLYING A WRAP DEFORMER
Next, unhide your 3D blanket by going into the 
Outliner located under Windows>Outliner. In 
the outliner select your 3D blanket and press 
Shift + H to unhide the 3D object.

Next, in the outliner select your 3D Blanket and 
then your 2D Plane (your nCloth), and in the 
Modeling Menu Set, go to Deform>Wrap>Options 
Box.

In the Options Box, Click Exclusive 
Bind and Click Create.



APPLYING A WRAP DEFORMER:
QUESTIONS

What is Exclusive Bind?

“When on, the wrap deformer’s target surface will behave like a 
rigid bind skin and 
Weight Threshold is disabled. Each surface point on the wrap 
deformer’s target surface will only be affected by a single wrap 
influence object point.

Note: Exclusive bind only works with polygon mesh target 
surfaces.”

(Autodesk Maya Definition)



APPLYING A WRAP DEFORMER:
QUESTIONS

What Does Using This Wrap Deformer Do?

Well, like the definition described earlier, a 3D nCloth does not work due to both 
sides of that object going through each other and penetrating.

With this deformer, we are not turning the 3D Blanket into an nCloth. We are using a 
2D Plane with the same number of vertices as the nCloth and then using a deformer 
on the 2D plane to lead the 3D object into what LOOKS like an nCloth.

All the 3D blanket is doing is changing the shape of its vertices to match the 2D 
blanket through the wrap deformer. 

This is how this is possible!



ANIMATION OF A 3D BLANKET
Now, since we have done all the 
steps above, the 3D blanket should 
follow the 2D blanket as a nCloth
and deform/change shape with it 
without penetrating.

To check this accurately, I took the girl in my file, made 
a few key frames of her laying down, and then her 
sitting up to see if it would follow appropriately. The 
effects of it are below!



ANIMATION OF A 3D BLANKET:
LAST THOUGHTS

Now that we have the nCloth
working appropriately. A last few 
things:

1) Make sure to hide the 2D nCloth
blanket (Ctrl + H)

2) Rewind back to frame 1
3) Save your Project!

That’s how you make a 3D Blanket 
Animate without self-penetrating!

Since this Technical Paper is focused on 
making a 3D Blanket able to move like an 
nCloth, and is not about an nCloth effect in 
the first place, please take note that there is 
much more information regarding the 
nCloth effect but is not spoken of or talked 
about inside this paper.

NOTE



FOR MORE IN DEPTH RESEARCH ON 
ANIMATING A HIGH-POLY BLANKET, 

LOOK BELOW:
The Below is taken word for word from a CGTalk Thread by DrYo User
“If it is thick cloth then your best option is to create a simple 2D plane for the nCloth simulation. Make 
sure it has enough geometry (squares only) to deform the way you want. Also model the thick 
blanket that will actually render. Use a Wrap Deformer to drive the renderable geometry with the 
nCloth. Make sure to turn Exclusive Bind on in the Wrap Deformer.”

“Use a Transform Constraint for each place on the cloth that you want the character to touch. Link or 
constrain the dynamic Constraint locator to your character and key the Enable attribute off, then on 
when the character picks up the cloth.”

“Optionally, you can use a Strength Dropoff ramp in conjunction with Dropoff Distance in the 
dynamic Constraint node. To make this work properly, select the vertices near the point of contact 
before adding the Transform Constraint. Or else use nConstraint > Add Members.”

“Most importantly, you must set the Space Scale in the nucleus node to correspond to the scale of 
your scene. For scenes at 1/100th scale, leave Space Scale at 1.0. For scenes modeled at 1 to 1 
scale, set the Space Scale to 0.01.”



PART 2: HOW TO CREATE A 
NORMAL MAP

Now we will be learning 
how to take the blanket 
that can be animated, and 
attach/create a normal 
map to add depth

As you can see
I took the flat plane, and 
the extruded blanket (3D 
model) and dropped it on 
something and duplicated 
the ncloth for this example. 
A spotlight is currently on it.

You need to make sure you 
have a light inside of the 
scene as it will help you see 
the normal map. 

This is  because all a normal 
map does is change the 
way light reflects off the 
object. It does NOT change 
the model geometry.



WHAT IS A NORMAL MAP?
“A normal map uses RGB 

information that corresponds 
directly with the X, Y and Z 
axis in 3D space. This RGB 

information tells the 3D 
application the exact 

direction of the surface 
normals are oriented in for 

each and every polygon. The 
orientation of the surface 

normals, often just referred to 
as normals, tell the 3D 

application how the polygon 
should be shaded.”

Pluralsight (Digital Tutors Blog)
Simply put, a normal map is three texture maps laid 
over one another in the x and y and z direction using 
the RGB scale that does NOT add geometry but 
gives the illusion of depth.



UV THE OBJECT

UVS! They are extremely important. Before 
Texturing and Before creating your Normal 
Map, make sure to UV your object. 

As you can see, I have already done so. 
This way my object knows how to take in 
the texture when its time to render, 
appropriately.

Uving is very important part to this process 
but will not be discussed during this paper.

UV’s



Once UVing is completed, we 
begin by taking your object, 
and assigning a material to it. 
You do this by selecting the 
material, right-click + hold and 
select “Assign New Material.” 
A menu will pop up allowing 
you to select a material. We 
will choose “Lambert” as it is a 
shader within Maya that is 
good for a fur blanket (since 
we don’t want shininess/ a lot 
of light reflectivity).

ASSIGNING A SHADER



IMPORTING YOUR TEXTURE INTO
THE SCENE

Inside of your 
attribute editor, 
click on the 
lambert node. 
Once inside, on 
the line that says 
“Color” click the 
checkerboard 
box to the right.

1

2

This will make a 
menu pop up 
again. This time 
around, choose 
“File.”



IMPORTING YOUR TEXTURE INTO
THE SCENE

Once open, select 
the file image to 
the right of “file 
name.”

In the pop-up 
window, select your 
desired texture (I 
grabbed mine from 
the internet for the 
sake of this tutorial), 
and click “Open.”



THE RESULT OF ADDING 
HIGH-DEF TEXTURES

From first look, it looks great and 
realistic! 

BUT if we check the blanket out 
from another angle with the 
camera, we can see that textures, 
by themselves, have no illusion of 
depth.

So now we will create the normal 
map and then add it to see how 
this changes.



CREATING A NORMAL MAP

Step 1: Open Photoshop

Step 2: File > Open and 
select the current 
texture assigned to 
your object (or in this 
case, our blanket)

Step 3: Photoshop 
opens your texture 
and turns it into a layer



CREATING A NORMAL MAP
Step 4: Select the layer

Step 5: Go to Filter > 3D > 
Generate Normal Map 
(Note that you need Photoshop 
Extended to access this menu. 
You find that by going to 
Help>System Info.)

Photoshop will then think 
for a moment or so and 
then it will turn your 
texture into a beautiful 
multicolor painting.

As you can see, the 
normal map follows the 
texture in RGB.



TWEAKING A NORMAL MAP

As you might have 
noticed, along with the 
normal map appearing, 
a pop-up box appears 
with it. 

This box allows you to 
tweak the normal map in 
a way that benefits 
YOUR PROJECT.

Invert Height: inverts the raised 
grooves on your normal map

Blur: blurs your normal 
map

Detail Scale: allows 
you to add or 
remove detail from 
your normal map

Contrast Details: This 
deals with contrast 
of  the texture. You 
can either grab the 
arrows and raise and 
lower them to 
subtract or add 
contrast, or plug in a 
percentage.

Material Preview: allows you to tile as well as offset the 
u/v and x/y preview, etc.

Object: allows you to 
display your texture on 
different primitive objects

3D Move: allows you to interactively view the texture on the sphere.

Allows you to change the light you view 
the texture on the sphere with.



TWEAKING A NORMAL MAP
When you are done, hit OK, and the 
texture updates in Photoshop.

This is what  my viewport looked like 
when I hit OK.

The original Normal Map

The new normal map after my 
tweaks



EXPORTING A NORMAL MAP
When completed, go to File > Save As 
and make sure to RENAME the file (don’t 
save over your original texture) and click 
“Save.”

Back in Maya, select the object



ASSIGNING THE NORMAL MAP

In the shader node (Lambert), find 
“Bump Mapping” and select the 
checkerboard box to the right of it. In the 
pop-up window, choose “File” again.

This will switch on the “Bump Map” node.

In the “2D Bump Attributes,” click the 
“Use As: Bump” box and change it to 
“Tangent Space Normals.” 

Lastly, click the arrow next to “Bump Map 
Value”

Remember that a Normal Map is just a three 
bump maps in the x, y, and z direction.

NOTE



ASSIGNING THE NORMAL MAP

Inside of the Normal Map 
node, select the folder 
image to the right of “Image 
Name” and select your 
normal map file and click 
open.



WITH VS WITHOUT
Now when you render it with the normal map on it, 
this is what you get! Now, it may be hard to tell, but 
the detail in this image does make the fur appear 
more raised.

Without a Normal Map

With a Normal Map
For example, you can see on this 
piece of fur I circled in red, that the 
one with the normal map has more 
detail on it, and looks more raised 
than the previous version without it.

NOTE



I turned the filter type to off inside of the normal 
map as the “Quadratic” setting tends to add a 
blur.

I also jumped into the fur texture itself and 
played with some raytrace options having to do 
with surface thickness, etc.

MAKING ADJUSTMENTS

Now, I decided to go back into some settings and 
move some attribute bars around and such to make 
the lighting a little different and bring out more 
quality in the normal map:



MAKING ADJUSTMENTS

I also jumped into my Render Settings, make my 
render image itself HD 540 to get more info on the 
pixels, etc, and turned off “Enable Default Light.” 

I also improved the overall quality and lighting 
quality in Render Settings.

Lastly, I jumped into the spotlights Attributes and 
turned on Raytrace Shadows (as your image will 
display none if you don’t turn this on), and added 
more shadow rays, depth limits.



THE END RESULT



SUMMARY OF PAPER

And that’s it! Again, just to summarize, we walked through how to: 

1) Create a three dimensional nCloth with an actual thickness and allow it to be 
animated like an nCloth

AS WELL AS

2) how to add a normal map to create the illusion of depth on a high-poly model to 
give it added complexity

That’s the end of the technical paper, hope you enjoyed!
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