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Bendy Arms Tech Paper

One of the problems we ran into during our film was how Benfolio’s arm would
deform. When working with any basic rig, you have typically have an arm rig with four
joints: one at the shoulder, one at the elbow, one at the wrist and one in the palm of the
hand. This allows the model’s arm to deform at the elbow similar to a normal human
arm. This works fine for most any character. But with Benfolio it was decided very early
on that not only would he have capabilities to stretch his arms but they would be very
noodley, almost like wires or tubes. This rig can function on it's own, so for the purposes
of this tutorial | will not be going over how to create a basic skin arm rig. However, | will
be showing how to implement this into a skin arm rig.

1. Import clean geometry of your character. This geometry can be unfinished but like
every rig, the proportions must remain consistent through every iteration of the
model or you will need to restart. Which you do not want to do!
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Image of Benfolio’s basic rig before beginning the process and a close-up of his arm, where we will
be starting. For this tutorial we will be rigging his right arm.

2. If you are starting without a basic rig like | am, you’ll need two groups that have
already been implemented into this rig. r_arm_doNotTouch_grp and r_arm_grp. The
prefix r is for the right arm specifically, so if you are rigging the left arm you will need
to name them |_arm_doNotTouch_grp and |_arm_grp.

3. Create the ribbon plane. This will run through the whole arm and serve as our base.
- Create > NURBs primatives > planes > options

Edit Help

User defined

Width:
Length: 1
Surface degree: # 1 Linear

U patches:

V patches: 1

Create Close




Settings of create NURBSs plane. The width can be adjusted depending on how much control you

want.
Move nurbs plane into position inside the arm.
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- Delete history (Edit > delete by type > history) and freeze transforms (Modify >
freeze transforms).

- Rename and parent to arm_doNotTouch_grp as shown below. Don’t worry about

the follicles group at the moment.

ar arm_doMNOTTouch_grp

= |_arm_follicle

I_arm_ribbon_plane

r_arm_ribbon_plane

Next, we will need to create a hair system. This will allow us to later on, parent our
joints into the exact center of each section of the ribbon plane.

- Go to nHair > create hair. Change your settings to those shown below.
M Create Hair Options — O x

Place I hair system

Create Hairs Apply




Settings | used for creating the hairs. If you increased the width value on the nurbs plane you
created, you will need to make sure the U count is the same value here.

Delete hairSystem1, hairSystem1OutputCurves, and nucleus1 in the outliner
In the HairSystem1Follicles, shift+ to expand and delete all curve nodes leaving
only the follicles. All the curve nodes should be parented under each follicle.
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Rename arm follicles rArmFollicle1, rArmFollicle2, rArmFollicle3, rArmFollicle4,
rArmFollicle5, rArmFollicle6, rArmFollicle7, rArmFollicle8, rArmFollicle9.
Rename the hairsystem1Follicles group r_arm_follicles_grp and parent under
r_arm_doNotTouch_grp

. Creating the joints.

Go to Skeleton > create joints in the rigging menu

Click on the grid in an orthographic view to create one joint. Then with the joint
selected in the outliner, click ctrl + d to duplicate it 8 times for a total of 9 joints.
This will change depending on how many follicles you have.

Group the joints by pressing ctrl+g and rename the group “r_arm_skin_grp”
Rename joints r_arm_skin_joint_1, r_arm_skin_joint_2, r_arm_skin_joint_3,
r_arm_skin_joint_4, r_arm_skin_joint_5, r_arm_skin_joint_6, r_arm_skin_joint_7,
r_arm_skin_joint_8, r_arm_skin_joint_9.

Click rArmFollicle1 as the leader and then r_arm_skin_joint_1 as a follower and
then to Constrain > Parent > O options

Uncheck Maintain Offset



Constraint axes:

Translate:

Close

- Repeat with each follicle and joint by pressing ctrl+g to repeat the last performed
action. this should move all joints into place.
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6. Cut geometry into pieces with each piece centered on one of the joints. This is used
for proxy geometry and takes much less time to cache and playblast so this is good
for animation to prevent maya from slowing down. | used a command for this, but |
will be showing you how to do it manually (haha) If you plan on skinning these joints
you may skip this step.

- Go to Mesh Tools > Multi-cut tool.



On the right side of the screen, click modeling tools and scroll down to “slice tool”
and hit the arrow to expand. Check extract faces. Change the values from 0.5 to
0.0.
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In the viewport menu, go to Panels > Orthographic > Front. This will be very

helpful in lining up your cuts.
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Click off the geometry once to create a point, then, shift click and drag on the
other side of the arm to create a plane. Try to keep this as close to your joints as
possible.

Continue for each joint until the geometry has 7 slices excluding slicing over the
two edge joints. This is a personal preference but joints 1 and 9 are too close to
the shoulder and hand to me to need to be cut. This may change depending on
your rig.

Right click and go into edge mode

Object Mode

Vertex Uy

Vertex Face Multi

Double click on the sliced edge to select it all the way around.

Go to Edit Mesh > Detatch and then Mesh > Separate.

Repeat until you have 8 pieces of geometry

Reorder geometry so it’s in sequential order with each piece moving up the arm
then rename r_arm_geo_1,r_arm_geo_2,r_arm_geo_3,r_arm_geo_4,
r_arm_geo_5,r_arm_geo 6,r_arm_geo_7,r_arm_geo_8.



- Parent and scale constrain r_arm_geo_1 to r_arm_skin_joint_1. Repeat for
remaining joints by pressing g to repeat the command. | recommend you parent
constrain each joint first and then scale constrain each joint.

. Prepare your joints for the bend controls.

- Duplicate r_arm_skin_joint_1, r_arm_skin_joint_3, r_arm_skin_joint_5,
r_arm_skin_joint_7, r_arm_skin_joint_9 and delete the constraints. Change the
radius on each joint to .8 so they are slightly bigger than the rest of the arm skin
joints.

- Rename r_arm_skin_joint_10 to r_hand_skin_jnt (closest joint to hand)

- Rename r_arm_skin_joint_14 to r_up_arm_skin_jnt (closest joint to shoulder)

- Rename r_arm_skin_joint_11 to r_bendy_arm_low_anim (joint in the middle of
hand and elbow)

- Rename r_arm_skin_joint_12 to r_bendy_arm_mid_anim (joint on top of elbow)

- Rename r_arm_skin_joint_13 to r_bendy_arm_up_anim (joint in the middle of
elbow and shoulder)



Outliner
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This next step will require a lot of parenting. Here, | will explain where | placed each

joint in my already existing rig. If you are not working off a base, don’t worry. All you

will need to do is parent each joint in the same order in the hierarchy of the outliner

which | will show at the end.

- Parent r_hand_skin_joint under r_hand

- Parentr_up_arm_skin_joint under r_up_arm

- Go to create > Nurbs curves > circle

- Move it into the arm, hold down the v key to snap it into the center of the elbow
joint and resize.

- Freeze transformations and press ctrl+g to group. Name the group
r_bendy_arm_mid_anim_grp



Parent r_bendy_arm_mid_anim (joint) to r_bendy_arm_mid_anim (nurbs curve)
Duplicate r_bendy_arm_mid_anim twice and delete the duplicated children.
Rename r_bendy_arm_up_anim and r_bendy_arm_low_anim

Snap the controllers into r_bendy_arm_up_anim (joint) and
r_bendy_arm_low_anim (joint) using the v key. Then freeze transformations on

both controllers.

Forr_bendy_arm_mid_anim_grp, r_bendy_arm_up_anim_grp,
r_bendy_arm_low_anim_grp you will need to center the pivot of the group inside
each joint by going to modify > center pivot or by hitting the d key on the
keyboard and then holding down the v key to snap the pivot into the correct
location.




- Group r_bendy _arm_up_anim (controller) and name the group
r_bendy _arm_up_anim_grp

- Group r_bendy _arm_low_anim (controller) and name the group
r_bendy _arm_low_anim_grp

- Parentr_bendy_arm_up_anim_grp under r_up_arm

- Parentr_bendy_arm_low_anim_grp under r_log_arm

- Parentr_bendy arm_low_anim (joint) to r_bendy _arm_low_anim (controller)

- Parentr_bendy_arm_up_anim (joint) to r_bendy_arm_up_anim (controller)

- Selectr_bendy _arm_up_anim (joint), r_bendy_arm_low_anim (joint),
r_bendy _arm_mid_anim (joint), r_hand_skin_jnt, |_up_arm_skin_jnt, then
r_arm_ribbon_plane. Go to Skin > bind skin > options. Make sure you have Bind
to: Selected joints and Max influences set to 3.

M Eind Skin Options - O pd
Edit Help
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Bind Skin

These controllers should now work in both fk and ik but each has to be moved

individually. If you want the controllers to follow the center control better to give a

more natural look then you can follow these steps.

- Selectr_bendy_arm_mid_anim and r_hand_skin_jnt. Make sure to select
r_bendy_arm_low_anim_grp last. Then go to Constrain > point with default
options.
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Select r_bendy_arm_mid_anim and r_up_arm_skin_jnt. Make sure to select

r_bendy_arm_up_anim_grp last. Then go to Constrain > point with default
options.

Display  Show
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Select r_bendy_arm_mid_anim (controller) then select
r_bendy_arm_up_anim_grp and go to constrain > Aim.
Select r_bendy_arm_mid_anim (controller) then select
r_bendy_arm_low_anim_grp and go to constrain > Aim > options. You will want

to adjust the Aim vector on x (the first box) to negative one so that it points back
towards the elbow.



M Aim Constraint Options — O >
Edit Help

Maintain offset:

World up vecton:

Constraint axes:

Weight:

Close

Aim constraint options. This will change based on which arm you are rigging.

10. | found that this helps control the arm quite well, but my directors weren’t 100%
satisfied. They wanted to be able to move his shoulder independent of the rest of the
arm and bendy controls. So if you want even more control, here is how to add a
shoulder controller.

Go to Skeleton > Create joints. Click anywhere on the grid to create your new

joint. Once it is created, move the joint into the pivot of your shoulder by pressing

v. Rename this joint r_bendy_shoulder_joint.

- Once your new joint is in place, parent it on top of the r_up_arm_skin_jnt. Make
sure this new joint hierarchy is in the same place the r_up_arm_skin_jnt was in
previously.

- Go to Create > NURBSs primatives > circle. Or duplicate r_bendy _arm_up_anim
and delete the children. Move this nurbs curve so the pivot is inside
r_up_arm_skin_jnt. Rename r_bendy_arm_shoulder_anim.

- With r_bendy_arm_shoulder_anim selected, press d on the keyboard and then v
to move the pivot into r_bendy_shoulder_joint.
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Final Hierarchy.



- Select r_bendy_arm_shoulder_anim. On the right side of the screen, go into the
channel box and select Translate X, Translate Y, and Translate Z. right click and
select “lock selected.” This will prevent your animators from moving his shoulder
out of his socket.
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- Finished!




(it looks a lot better skinned.)

Rigging and arm with these controls can be useful for several reasons, if you
want a character to deform in a goofy, cartoonish way then this can be useful for
exaggerating poses. Having a single ribbon plane arm like this is also useful for allowing
for a nice rotation of the whole arm when the hand control gets rotated as well, much
like our own arms. This could probably be put to use to create bendy legs as well if you
wanted to rig a character with stretch on all four limbs to emulate a rubber hose style or
if your character is some sort of noodle monster. It could also be useful for having more
control when you need to cheat the length/angle of a limb in a specific camera angle.
This level of control is definitely not always necessary, but | hope someone finds this
useful on a film in the future.



