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Hi there! 

This tech paper covers the basics of creating a simple 2D rigged element in Toon 
Boom Harmony. The process described here is applicable to most any basic 2D prop or 
object you might want to add to your film. The film I worked on combined major 2D and 
3D elements, but this can also be useful if you are using Harmony to create animated 
elements on flat surfaces or cartoon graphics for your primarily 3D film. I won’t be 
covering everything necessary to rig an entire 2D character, but the basics of making a 
2D simple prop transfer to large scale rigs as well. 

 
A properly rigged object, even if it is a simple object that doesn’t do much more than 
rotate or bend slightly, is key to making your animator’s lives easier.  
 

 

 

SETUP 
 

Harmony is a rather fickle program, and proper settings are key to 

avoiding future issues. Ensure you have the following settings before 

starting on your prop or scene by doing the following: 

 

❖ Go to Edit -> Preferences  

❖ (On MAC it may be under Harmony Premium -> Preferences) 

➢ Under the GENERAL tab (This is the tab you start on by 

default) use the following settings: 



 

-Ensuring Separate positions and scales on Peg is important because it 

allows animators to key movements on each axis seperately 

-Checking “Stop-Motion Keyframes” is important for setting keys later 

on the object. 

 

❖ Under the ADVANCED tab use the following settings: (taking 

special care to ensure “Support Overlay and Underlay arts” and 

“Element Node ‘Animate Using Animation Tool’ Default Value” are 

checked and unchecked, respectively. 

 



❖ SHORTCUTS: For ease of use (and because Harmony’s default 

shortcuts are bordering on unusable) I will be using these 

shortcuts, and referring to them throughout this paper. I 

recommend setting these yourself under Edit -> Keyboard Shortcuts 

(On MAC it may be under Harmony Premium -> Keyboard Shortcuts) 

 

N - Pencil Tool 

G - Paint Tool 

V - Stroke tool (invisible line) 

1 - Zoom Out 

2 - Zoom In 

3 - Select tool 

4 - Snap to contour toggle (for connecting points) 

5 - Apply to Line and Color art Toggle 

6 - Paint Tool 

8 - Pencil Editor Tool (line thickness adjustment 

Alt + Q - White arrow select tool 

Alt + Shift + D - Duplicate new drawing substitution 

F/G - switch between drawing substitutions 

 

❖ When you open your new scene, in the node view window (You can 

bring this up under windows if it isn’t already present in your 

scene) you should see a drawing already there and connected to 

the composite node. DELETE IT. It’s cursed and we don’t want to 
touch it. 

 

 

❖ Also delete all the default colors in the scene (Under the color 

window): they also have the ability to cause us problems and junk 



up our scene later on in production. Simply select and hit delete 

until no colors are left. 

 

❖ Hit the + button in the top right to add a fresh, new, 

unproblematic color. 

 

❖ Doubleclick the swatch to edit the color, and doubleclick on the 

name to rename it. Because our prop uses black outlines, it’s 

safe to call this color “LINE” and assign the color value to an 

RGB value of 5,5,5 

❖ (You need to have a drawing node selected to do this, so if you 

already deleted the initial drawing, simply come back and do this 

later) 

 

 

Creating the Object 
 

The first step to creating our prop is getting the reference art for 

it. If the object doesn’t turn all the way, we don’t need a full 

turnaround. Sometimes in the industry, you only get one reference image 

for a prop, but if you can, it’s always good to get whatever major 

angles you need from the person designing the prop. 

 

This is the prop we will be creating: 



 

 

 

 

 

 

 

To import the image go to File -> Import 

-> Images 

 

Hit Browse and locate the image you are 

referencing 

 

Import it as a Toon Boom Bitmap Drawing, 

and hit OK. 

 

 

The drawing will appear in the Node View 

as a light blue tvg node. 

 

 

 



Open the Node Library. Search for and drag a Colour-Card (This is a 
canadian program, you need to include the U to properly search it) and 

a Transparency Node into the node view. 

 

Click and drag the blue boxes at the bottom of the 3 nodes you’ve 

created like the image below: feeding the reference image (Pen [tvg] in 

the screenshot) through the transparency node and into the composite, 

and feeding the colour card into the RIGHT of the artwork. 

 

--- WHY RIGHT?  

- Harmony’s Composites are like layer groups in photoshop. The 
composite in the scene here serves to flatten the incoming image data 

before sending it to the display and write nodes. Instead of having 

lower layers be below others physically in the display, the hierarchy 

moves from left (top) to right (bottom). You can always check which 

side is the bottom of the composite by looking for the connection with 

the black dot. (In my image, this is the color card connection) 
 

 

 

 

 

 

 

 

 



With this setup: My Camera view looks like this: 

With the reference image faded out and visible. 

 

 

❖ The Pen is nearly the height of the camera window! This pen is 

far larger than what it needs to be for the scene, so lets scale 

it down a bit! To do that, or to move ANYTHING beyond individual 
strokes, the best practice is to add a PEG. 

❖ A PEG is a node that holds transformation information, and it can 
be animated! All drawings in our 2D objects MUST have a peg to be 

animated. Adding the pegs correctly is a large part of 2D 

rigging! 

❖ To add a PEG, select the drawing node you want to add it to and 
hit CTRL + SHIFT + P, or search for the peg node in the node 

library and drag it into the scene and connect it like so: 



 

 

This is the transform tool! It’s found on the main toolbar. 

Select it to move and scale things in the camera view. 

 

❖ With the Transformation tool selected, click on the Peg so that 

the drawing is highlighted yellow in the camera view: 

 

❖ Now you can scale it down to the approximate size it will be in 

the scene. Mine is this size: 



 

 

Now that we have our reference artwork in, We can add in the drawings 

we’ll need. For this pen, I am going to be creating six separate 

drawing nodes. That might seem like a lot, but each individual drawing 

is going to be a part that can be individually moved. The button, the 

pen tip, the clip, and the main body are all individual parts. I will 

also be adding 2 additional drawings to the body in order to get the 

perspective we want. 

 

ADDING THE DRAWING NODES: 

 

❖ Hit Ctrl + R to add a new drawing in the node view.

 



❖ Make sure it’s a vector layer, and name it accordingly. If you 

hit “ADD” you can add a new drawing immediately after. When you 

have enough drawings, hit “APPLY AND CLOSE” 

❖ Arrange the new drawing nodes next to each other horizontally, 

with the lowest element on the right and so on. 

❖ Drag a new COMPOSITE node and position it under the new drawings. 

Rename it to PEN-C (or whatever the object name is -C) 

➢ Click the yellow option box on the composite node to enter 

the node settings: 

➢  

➢ Change the mode to PASS THROUGH. This will allow any depth 

data to maintain, and not flatten. 

❖ Add a PEG to the drawings by selecting all of them and using CTRL 

+ SHIFT + P to add pegs to all of them. 

❖ Connect the nodes like this: (The composite connects to the main 

composite the colour card is plugged into) 

 

 

Now we’re ready to insert our artwork! 
 

-Select your pencil tool, or hit N if you’re using my 

shortcuts, and select your “lines” color we made earlier. We want 



to use the pencil and not the brush, as the pencil allows for 

greater control of our strokes. 

Starting with just the linework, draw the art you need on the 

relevant drawings. 

 

Make sure to put this on the Lineart layer, as shown on the image 

to the side. This matters for creating more complicated things 

like clipping masks in the image. 

 

Toggle snapping on with 4 to connect vector points together 

 

Use the Select (3) and Direct Select (Alt +Q) to edit whole 

lines, and individual points respectively. 

Holding ALT while pulling vector handles breaks the handles into 

sharp corners. 

 

 

Use as few points as you can to 

get the stroke to be smooth 

 

 

 

Now that we have the lines in, it’s time to insert our 

colors! Open your reference art in a program like 

photoshop, since the colors can be altered on import 

into harmony. 

 

Make a new color swatch for each color you need, name 

it, and eye drop the color from the other application 

window to get the exact color you need. 

 

To set up each drawing for color, do the following: 

 

- Use the select tool to grab all the lineart 

-  Hit the Line art to Color art 

button at the top of the camera window (The button in 

the bottom middle that looks like an eyelash) 



- Select the Color Layer:  

- You should see the line stroke has been transferred to this 

layer: (the color layer highlights in blue when not being 

directly selected) 

 

 

- If the lineart isn’t a closed shape, use the 

stroke tool (V) to close the shape with an invisible 

line. (As shown on the left) 

 

 

-  Select the paint bucket tool (G) and fill 

the layer in with the right color. 

 

 

 

 

If your object is something simple like a single star, you only need 

one drawing layer. If this is the case, you can skip to Page 17 once 

you have that drawn. 

 

Otherwise, let's look into some things we notice with the fully colored 

pen: 

 



 

 

The Cap is behind the line of the (Pencutter) drawing, and in front of 

the Body of the pen. If I try and move it behind, it no longer reaches 

the line. 

 

I named this drawing “Pencutter” because it will be a cutting shape for 

a clipping mask we’re going to apply to the object. 

 

Let’s create a box shape using the stroke of the line of the pencutter 

art using the stroke tool on the Color art layer: (In this screenshot i 

hadn’t connected the box to the line yet, but you will need to do this) 

 

 



❖ Create a new color and make it something OBNOXIOUS that you’d 

never use in your scene. Name it MASK and fill this new shape 

with it: 

 

 

❖ That way, you know if a certain color is there for technical 

reasons, it will look obvious like this. 

❖ Next, drag a COLOUR ART, LINE ART, and CUTTER node into the node 

view. Hold ALT and drag the lineart node between the pencutter 

art node and the composite: The green should become invisible 

❖ This is because we are only feeding the visual information of the 

Line art Layer into the composite. We don’t want to see the 

green, but we DO want to use it. 

 

❖ Take the cutter node, insert it between the button art and the 

composite. 



❖ Drag a new line from the cutter art and feed it into the top of 

the colour art node. 

❖ Connect the bottom of the color art node to the left port of the 

cutter. This assigns the shape of the color layer at the masking 

shape for the pen: Hiding the shape. 

 

 

For the middle section, I also wanted to make 

it separate in case the animators want to 

adjust the perspective on the bands. I do 

something similar to cut this shape into the 

pen, but with a slight difference: 

 

Feed the body shape into the cutter, and 

click the mask shape to invert the mask so 

that instead of hiding the shape, it reveals 

it (Don't’ disconnect the Penbody from the 

composite, just drag a new line) 

 

 

 

 

 

 



 

 

However, now we have lost the linework in this 

section of the body, as the mask has covered it. 

 

 

 

Inserting an autopatch between the body and the 

cutter solves this issue, as now instead of the 

entire shape, it only reveals the middle drawing 

within the visible color art of the body. 

 

***AUTOPATCH NODES are like colour art nodes, but slightly heavier on 

computing power as they calculate the color art, but only what you see 

underneath the lineart layer. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Perfect! 

 

 

 

The last thing we need to do is set up our pegs and pivots! 

 

 

 

Find this button, the Rotate tool! 

 

 



 

 

 

 

Select any of the Peg Nodes in the node view, you 

should see a blue dot indicating the pivot location of 

that peg. In my image, it’s clear to see that the pivot 

is far out of the object. I don’t want my pen rotating 

around that point! I want it to rotate around a point 

inside. With the rotation tool on, drag the pivot into 

the location that fits best. Do this for all the 

different drawings in the scene. I’ve show some of my 

pivot placements below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



We’re almost done! 

 

We still want to be able to move the pen as a whole, so let’s make one 

more Peg and connect it to all the other pegs so that it can control 

all of them together: Don’t forget to set the pivot on this one too! 

 

I named my peg PenAll-P 

 

 

 

Select all the nodes in the image above and hit CTRL + G to group them 

into a single group node. Add a peg and adjust the pivot on the peg 

above the group like so: 

 

 

 



Select the peg and group, and hit CTRL 

+ C to copy them both.  

 

Next, in the LIBRARY WINDOW, right 

click on the Harmony Premium Library 

folder and select “right to modify” 

 

This allows you to edit its contents, 

and paste the group into the library! 

This will be obtainable in the library 

folder in your computer’s documents 

folder. 

 

 

 

 

There it is!! Pen_GRP-P completed and ready to be handed off to the 

scene where it’s needed! This can be dragged into any Harmony scene as 

the animators deem fit. 

 

If you need to add deformers to your object, there are many helpful 

online tutorials that can take you through that, but this is all I am 

going to cover in this paper. I hope this paper was helpful, good luck 

on integrating those 2D elements!  


