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How to Model Curly Hair 

 There are a few important notes to mention before we begin. First, this is just one of 

many, many ways that this task can be accomplished. I found it to be quite simple and effective 

in the end, so hopefully you will too. Second, this method will result in quite a bit of 

interpenetrating geometry. RenderMan 22 isn’t bothered by interpenetration as much as it or 

other renderers used to be, however issues could still arise. A commonly known issue with 

interpenetrating geometry results in faces or surfaces flickering due to the renderer’s inability to 

properly calculate the area. My team was able to avoid this due to our specified style in which 

we do not use specular maps. By just using diffuse maps, we create a flat, painterly style and also 

avoid the light interaction that often causes flickering errors. This is to say that this method to 

create curly hair may not work if the textures used include specular maps, but it is worth testing. 

Third, for this method, I used a free plug-in found online. This plug-in is not necessarily 

required, but it will save hours of time. Lastly, I would like to credit much of my success to the 

creator of this video: https://www.youtube.com/watch?v=CmgV7PA5Oo8&t=394s Feel free to use it 

to help you along the way. All good? Here we go! 

 

 

 

 

 

 

https://www.youtube.com/watch?v=CmgV7PA5Oo8&t=394s
https://www.youtube.com/watch?v=CmgV7PA5Oo8&t=394s
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1.     Create your character. 

  

 

I. Separate the head from the body. This is not only an important 
modeling point when creating a character, but it will make it easier 
to sculpt the hair pieces later. 
II. Only have the head showing, so hide all extra head pieces such 
as the teeth, tongue, eyes, etc. (Figure 1.3) 
III. Make sure the head is closed in the back. (Figure 1.2) 
 
 

2.     In edge mode, carefully select the edges around the area where hair is wanted. 

  

 

I. Persephone wears a hat, so she doesn’t need hair on the very top of her head. (Figure 2.2) 

Figure 1.1 Figure 1.2 

Figure 1.3 

Figure 2.1 Figure 2.2 
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3.     Under the Modeling menu set, go to 
Edit Mesh > Detach. (Figure 3.1) 

I. It’s best to do this part in non-
smoothed mode. Hit 1 on your keyboard 
to see your original model.  

 

4.     Go to Mesh > Separate. (Figure 4.1) 

 

 

5.     In your outliner, you will see that another piece of 
geometry has been created, and the original “head” 
geometry is now a group. (Figure 5.1) A transform 
node has also been created which is not needed. To 
delete this node, you will need to delete the history. 
Select the “head” group and go to Edit > Delete By 
Type > History. (Figure 5.2) 

 

6.     Select both pieces of geometry in the “head” group 
to discover which is the base and which is the hair 
piece. Duplicate whichever is the hair piece by pressing 
Ctrl + D on a PC or Cmd + D on a Mac, then select the 
original hair piece geometry and press H on your 
keyboard to hide it. Name the base piece “base,” the 
hidden original hair piece “hairPiece,” and the duplicate 
“hairPieceDuplicate.” (Figure 6.1) 

 

 

7.     We now want to make “hairPieceDuplicate” and “base” 
one object again. Select them both, then go to Mesh > Combine. 
(Figure 7.1) The new geometry will combine and be pulled out 
of the “head” group. Rename it “base” again if you have to, then 
pull it back into the “head” group. Delete the history on the 
group again. (Figure 5.2) 

 

8.     This part takes a minute or two. Around the parameter of 
the hair piece, carefully select each pair of vertices and go to 

Figure 3.1 Figure 4.1 

Figure 5.1 

Figure 5.2 

 

Figure 6.1 

 

 

Figure 7.1 
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Edit Mesh > Merge. (Figure 8.1) After clicking through this 
command once, however, you will be able to hit G on your 
keyboard to repeat the last command.  

I. Each pair of vertices will be right on top of each other and 
will appear as one vertex point as long as 
“hairPieceDuplicate” has not moved. Be sure to still select 
over the area that the vertices are in, however, to ensure both 
are being selected before merging them. 

II. Do not use the Symmetry feature for this step. It can cause 
the vertices to not merge. 

 

9.     Unhide “hairPiece.” The character should now have a full base piece, and a hairPiece 
directly on top of it. (Figure 9.1 and 9.2) 

  

 

10.     Switch to the FX menu set. Select “hairPiece” and go to nHair > Create Hair > Options 
Box. In the Options Box, go to Edit > Reset Settings. 

 

11.     In the dropdown menu under Output:, click on NURBS curves. Check the box that says 
Collide with mesh. Change the U count: and the V count: to 40. Change Points per hair: to 15. 
Change Length: to 4.5000. Click Create Hairs. (Figure 11.1) Another window will pop up 
asking if it is okay to generate hairs. Click Create Hair Curves. The character will look 
something like Figure 11.2. We love her. She is beautiful. 

Figure 8.1 

 

 

Figure 9.1 

 

 

Figure 9.2 
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I. It’s important to remember that these are just the settings I used for Persephone. These 
settings will vary based on character. 

 

12.     By pressing the Play button on your timeline, you will see the hairs drop. This is how we 
will begin to position the hairs. Try it out, then pull the timeline back to frame 1. 

 

13.     Select “base,” then go to nCloth > Create Passive 
Collider. (Figure 13.1)  

 

 

 

14.     In the Outliner, click on “hairSystem1.” Open the Attribute Editor by clicking the tab on 
the right side of the screen. Under the hairSystemShape1 tab, open the Collisions drop down 
menu. Check Self Collide at the top of the menu. A little further down open the dropdown menu 
under Solver Display and click Collision Thickness. (Figure 14.1) The hair will change to look 
something like Figure 14.2. 

Figure 11.1 

 

 

 

Figure 11.2 

 

 

 

Figure 13.1 
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15.      Open the Clump and Hair Shape drop down menu in the Attribute Editor. Change Clump 
Width to 0.350. Under Clump Width Scale, slope the line so it looks generally like Figure 15.1. 
Go to the start of the playback range or click the rewind button to load the new parameters. 
(Figure 15.2) 

I. As a reminder, these settings will vary based on character.  

 

Figure 14.1 

 

 

 

Figure 14.2 
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16.     Click on “nucleus1” in the Outliner. Open the 
Gravity and Wind drop down menu. If your character is 
facing forward on the grid, you will need to change your 
Wind Direction settings to 0.000 in the X and Y box, and     
-1.000 in the Z box. (Figure 16.1) 

I. If your character is facing another 
way, test the wind direction by 
bringing the Wind Speed up to 
50.000 (Figure 16.1) then press 
Play. The character’s hair should 
blow behind them, so change any 
parameters necessary so this 
happens. You can also just turn your 
character so that they are facing the correct direction for this tutorial. 

 

17.     Now it’s time to play with the Air Density and Wind Speed during the playback. These two 
parameters effect how the hair follicles fall throughout the 120 frames allotted. This part is 
completely subjective as all hair will fall differently and the look will be slightly different with 
every setting and every frame. For Persephone, one way to get the look I wanted was by setting 
the Air Density to 0.876 and the Wind Speed to 6.186. After finding settings you want to test, 
press the play button to see how the follicles fall. Stop the playback on a frame that gives you the 
shape that you want in the hair. For these settings, I stopped on frame 111.  

I. When you press play, you can’t go back to a previous frame. If you see a frame you liked but 
passed it, you must rewind back to frame 1 and play it again. 

 

Figure 15.1 

 

 

 
Figure 15.2 

 

 

 

Figure 16.1 
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18.     Click on “hairSystem1OutputCurves” group in 
the Outliner. Up in the menu bar, click nHair > Set 
Rest Position > From Current. Then again in the 
menu bar, click nHair > Set Start Position > From 
Current. (Figure 18.1) 

 

19.     In the Outliner, delete “hairSystem1,” 
“hairSystem1Follicles,” “nucleus1,” “nRigid1,” and 
“nRigid2.” 

 

20.     Open the “hairSystem1OutputCurves” in the Outliner. 
With the group selected, go to the menu bar and click Select > 
Hierarchy. (Figure 20.1) 

 

21.     Switch to component mode. (Figure 21.1) 

 

22.     Switch your camera view to right view. Select the points below the 
shoulders and delete them. 

I. Having above-shoulder-length hair is a common method for characters 
used in the industry. It takes away the constant interpenetration of hair 
through the shoulders. 

 

Figure 17.1 

 

 

 

Figure 17.2 

 

 

 

Figure 18.1 

 

 

 

Figure 20.1 

 

 

 Figure 21.1 
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23.     Shape the hair follicles by selecting points on the curves and moving them. You can do 
this individually or with Soft Select by pressing B on your keyboard. 

 

 

 

 

24.     Now it’s time for the plug-in. The downloaded folder is on the server named 
Spiral_Along_Curve, or you can download it yourself by going to: 

https://www.highend3d.com/maya/plugin/spiral-along-curve-for-maya 

I. If you can’t use the plug-in or choose not to, you can use the Curl tool by going into the 
Modeling menu set, selecting each curve, then going to Curves > Curl. There is an option box 
where you can play with the parameters until you get your desired effect. 

Figure 22.1 

 

 

 

Figure 22.2 

 

 

 

Figure 23.1 

 

 

 

https://www.highend3d.com/maya/plugin/spiral-along-curve-for-maya
https://www.highend3d.com/maya/plugin/spiral-along-curve-for-maya
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25.     Right-click on the spiral_along_curve.py file and open it in any code editing program. 
(Figure 25.1) 

 

26.     Copy the code starting with:  

import pymel.core as pm 

and ending with:  

spiralAlongCurveUI() 

 

27.     In Maya, open the Script Editor by going to 
Windows > General Editors > Script Editor 
(Figure 27.1) or by clicking the icon in the lower 
right corner of the screen. (Figure 27.2) 

 

28.     Switch to the Python tab, then paste the code 
into the box. To run the code, hit Enter on your 
numeric keypad or in the menu bar click 
Command > Execute. (Figure 28.1) A pop up will 
appear named Spiral Along Curve. (Figure 28.2) 
You can minimize this or put it off to the side for 
now, but don’t close it. If you do by accident, run 
the code again to get it back. 

Figure 24.1 

 

 

 

Figure 25.1 

 

 

 

Figure 27.1 
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Figure 27.2 

 

 

 

Figure 28.1 

 

 

 

Figure 28.2 
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29.     Now we need to set a few things up to 
ensure the plug-in works. Change to the front 
camera and move to the side of your character. In 
the menu bar, go to Create > Curve Tools > CV 
Curve Tool. (Figure 29.1) Create two large 
curves. (Figure 29.2) 

 

30.     Select the first curve. In the Modeling menu 
set, go to Curves > Rebuild > Option Box. Change 
Number of Spans: to 44. Click Rebuild. (Figure 30.1) 

I. This number may vary in the end, but it is a good starting 
place.  

 

31.     Go to Curves > Curl > Option Box. Change Curl 
amount: to 2.000. Click Curl Curves. (Figure 31.1) Your curl 
should look something like Figure 31.2. If it doesn’t, repeat 
steps 30 and 31 with slightly different values. This part isn’t 
critical by any means, but it helps create a base for the look of 
the curl. 

I. This number may also vary in the end, but it is also a good starting place.  

 

 

 

 

 

Figure 29.1 

 

 

 

Figure 29.2 

 

 

 

Figure 30.1 

 

 

 

Figure 31.1 
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32.     Select the second curve and go to Curves > Rebuild. 
Now bring back the Spiral Along Curve box. With the curve 
still selected, click Create Spiral! If another curve is created 
that curves or spirals around the selected curve, this means that 
it is working.  

I. If your plug-in doesn’t appear to be working properly, click 
off the curve and reselect it, then try again. You can also try 
closing the plug-in box and running the script again.  

 

33.     Delete the curve that has just been created. Every time 
that you create a new curve and want to try different settings, 
delete the old curve. This is very important! You will regret it if you don’t. From now on, save 
your project often just in case. 

 

34.     In the Spiral Along Curve box, change Radius to 4.000, Step to 0.025, and Ratio Step to 
0.400. Then change the slope of the graph to look similar to Figure 34.1.  Select the second curve 
and click Create Spiral! Remember to delete any previous curve you made around the second 
curve. Your curve should end up looking something like Figure 34.2. If it doesn’t, change the 
settings slightly. 

I. These settings may also vary in the end, but it is also a good starting place. 

 

 

Figure 31.2 

 

 

 

Figure 34.1 
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35.     Select these three curves and hide them. Switch 
back to the perspective camera and find your character. 
In the Outliner, open the “hairSystem1OutputCurves” 
group and select the first curve in the list. Rotate your 
camera so the selected curve is visible in the viewport.  

 

36.     With the curve selected, click Create Spiral! in the 
Spiral Along Curve box. Most likely you will end up 
with a curve that looks something like Figure 36.1. This 
is okay because we are going to adjust the settings again. 
If you curve doesn’t look like you would like for the 
hair, delete the curve you just made and reselect the first 
curve in the “hairSystem1OutputCurves” group. 

 

37.     In the Spiral Along Curve box, change Radius to 
0.210, Step to 0.220, and Ratio Step to 0.552. Click 
Create Spiral! (Figure 37.1) I found that these 
parameters create a nice, soft, natural curl. Play around 
with the settings to create the curl you hope for.  

 

38.     This part takes a while. In the Outliner, click each 
curl one by one, clicking Create Spiral! in between. Do 
not try to grab them all at once—this will break Maya 
and the plug-in and your happiness. Your result will 
look something like Figure 38.1. 

 

 

 

 

 

 

 

 

 

Figure 34.2 

 

 

 

Figure 36.1 
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39.     In the Outliner, hide the “hairSystem1OutputCurves” group. Open the “spiral_grp” group 
and select all the curves inside. Go to the menu bar and click Bonus Tools > Modeling > Curve 
to Tube Mesh. (Figure 39.1) You should end up with something like Figure 39.2. 

 

 

 

Figure 37.1 

 

 

 

Figure 38.1 
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40.     In the Channel Box/Layer Editor, change Width to 0.25, 
Taper to 0.3, Length Divisions to 20, and Width Divisions to 5. 
(Figure 40.1)  

 

41.     Some of the tubes appear black. (Figure 41.1) To fix this, 
select each tube that is black and in the Channel Box/Layer 
Editor, change Orientation to 180. Your result should look something like Figure 41.1. 

I. I found that this part is easier if you hide the head and body of the character and the 
“spiral_grp” group. 

 

Figure 39.1 

 

 

 

Figure 39.2 

 

 

 

Figure 40.1 
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42.     In the Outliner, hide the “spiral_grp” group. Open the 
“tubeMeshes” group and select all the meshes. In the menu bar, 
click Mesh > Fill Hole. (Figure 42.1) Re-click the “tubeMeshes” 
group in the Outline and hit 3 on your keyboard. This brings you 
into smooth preview where you can see how your hair is 
looking. (Figure 42.2) You can now delete “hairPiece” in the 
Outliner. 

 

43.     The rest is all about shaping. In vertex mode, use soft 
select to move around hairs and give them variation. On 
Persephone, I added her hat and bangs back, and I tried to get rid of as much interpenetration as 
possible by moving points by hand. I also deleted lots of strands that didn’t have an impact on 
the shape of the hair. The figures below are the final result. Good luck!  

     

Figure 41.1 

 

 

 

Figure 42.1 

 

 

 

Figure 42.2 

 

 

 

Figure 43.1 

 

 

 

Figure 43.2 

 

 

 

Figure 43.3 

 

 

 


