
Clean Models for More Efficient Render Times 

This paper includes some different tricks for ensuring clean models with reduced topology to help lower render times, and 

a quick way to layout out multiple UVs across different UDIMs for a single Shading Group.  

Deleting Faces 

When cleaning a model, one of the things you will have to do is delete unnecessary faces. Unnecessary faces are faces that 

will never be seen by the cameras. For example, if your object is stationary and the bottom and back are never seen, then 

those faces can be deleted. Deleting unnecessary faces reduces the polygon count for the model, which helps reduce Maya 

calculation time and therefore, render time later down the line, which is especially helpful in large files.  

To delete the faces, you have to first select them, and there are multiple ways to quickly select these faces. These tricks 

can be used to quickly select faces, edges, or vertices.  

Remember: With a face (edge or vertex) selected, to click and add another you must be holding down Shift.  

1. In Face mode, you can hold down the Tab key to brush select faces.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

a. Faces that are red, like in the above image, are 

being selected. 

b. If the faces are green, they are being deselected. 

Orange faces are selected. 

c. Note: If you start selecting on a new unselected face, then it will continue to only select new faces and ignore 

previously selected faces. If you start selecting from a selected face, then it will only select selected faces and 

ignore all unselected faces.  

d. After you have selected the faces (edges or vertices) you would like to delete, just hit the Delete key. 

 

2. You can turn on camera-based selection. 

 

Double click on the Select Tool to pull up the Tool Settings. 

 



• In Tool Settings, check “Camera-based selection.” 

 

• Close that menu and return to your model. By checking this, you can drag select (marquee) across your model, 

and instead of selecting all the faces in the marquee (front, back, side etc.) you are only selecting what you and the 

camera can see. From this point, you can switch to the back camera (or whichever camera gives you the right 

view). 

• To select a different camera, in the Viewport, go to Panels > Orthographic. Here you can pick one of the three 

common cameras, or there are more options under New, like Back and Bottom.  

      
 

• Once in the new camera you can marquee the area you want to select: 

                      



• As you can see, only what was seen by the camera was selected, nothing along the sides or those facing upwards 

were selected. In this case, some faces were missed but with one of the other tricks they can quickly be selected.  

    
3. One last way to quickly select faces (edges or vertices) is to select a face, go down to the end of the row/column and 

while holding down Shift, double click on the last face. This will select all the faces in the row/column.  

                            
• When cleaning these models, you might be deleting edge loops. When deleting edge loops, if you hold down 

Control when you hit Delete it will delete the edge(s) and the vertices. This saves you from having to go back and 

select the vertices to delete them. 
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Merging Vertices 

• When cleaning you might have to remodel or adjust a specific area. If the model is symmetrical, you can clean all 

of this on one side and then duplicate it to create the other side. The following tricks will help make merging these 

pieces back together easier.   

• Ideally, when merging you want the vertices to line up/match. Like with selecting faces, there are multiple ways 

to do this. 

• Half of this model has been cleaned and is almost ready to be duplicated and merged back into one model. The 

merge edge though has problems. Some of the vertices are not properly aligned and some are just not clean. 

 
• To clean this, the faces need to be flattened and then snapped back into the right positions. 

• To flatten faces, edges, or vertices, select them, switch to your Scale Tool with the R key, and then scale to 

flatten. You will want to select more than just the vertex that is out of place.  

 

• This vertex is forward further on the Z axis than its fellow vertices. By grabbing the Z axis scale, you can flatten it 

to match with the other vertices.  

 



          

• When you scale to flatten, it pulls all the vertices to the average distance. So, to get the vertices back to where 

they belong, you can snap them to the right spot.  

• With the vertices selected, switch to the Move Tool (W). Holding down the V key while moving on any of the 

axis will snap it to relative points. In this case it will snap and align to the position of nearby vertices.   

            

• You can then use this same method to realign any of the other vertices or edges. 

• TIP: If you are having trouble getting it to match to the correct point of reference, while still holding down your 

left mouse button, you can move the cursor towards the point of reference you want to match. You can snap 

objects, faces, edges, and vertices.  

 

• Now this piece is ready. To finish, this 

half needs to be duplicated and then 

merged with the first half.  

Drag in 



Duplicating and Merging Vertices 

• TIP: Keep in mind where the pivot is located. If you have not touched it and it is still centered (with the whole 

model) then you are good, but if you have moved it, then you want to make sure it is at the edge where you will 

be merging. So that when you duplicate and adjust the Scale X value, it will flip over into the correct spot. Pivot 

location can be adjusted with the D key, you can click on a point of the model to place the pivot or drag it into 

place and holding left mouse button gives additional options.  

• You want the pivot to be aligned with this edge: 

 
• Duplicate the object with Ctrl + D, and then change the Scale X value to -1 on the duplicated half to flip it. 

 

• The next step is remerging these two halves together. This is where making sure the vertices are all aligned, and 

the pivot was in the right spot comes in handy. If you had them all in a vertical line and the correct pivot, then 

they will align perfectly and merge the first time, this eliminates you having to go in and merge vertices 

individually.  



• To merge, select the two halves and go up to the top menu bar, then Mesh > Combine. 

 

• After this, you are going to want to delete history. This will remove the transform nodes that show up in the 

outliner after combing the meshes. Make sure the combined geometry is still selected, then Edit > Delete by Type 

> History (Alt + Shift + D). 

 

• Then go into Vertex mode, select the vertices, and then go to Edit Mesh > Merge > options. 

 



• You want the value to be low, at 0.0001, so it will not merge vertices that are close to each other that you do not 

want merged. Hit Merge once you have set the value. 

 

• Now, if you had all the vertices aligned, this works the first time, but when there are a lot of vertices it is easy to 

miss one. A trick I use to spot when this happens, is using the Append to Polygon tool. This tool is designed to fill 

in holes in geometry. It allows you to select an open edge, and then it highlights any other open edges you can 

attach to. This helps with missed merged vertices because the edges attached to those vertices will be unattached 

to each other, which means they will show up when using this tool.  

• To use this tool, you want to be in Edge mode, then go to Mesh Tools > Append to Polygon. 

 

• Select an open edge. An open edge would be an edge not connected to another face, like the edge created by 

deleting faces.  

 



• If merged successfully, you get no purple along the merged edge like in the previous image, but if you missed 

any, it will look something like this. 

 

• This means that vertices were not merged properly, but by using this tool you can see exactly which vertices did 

not merge, which makes grabbing those vertices and merging them easier. If it still does not merge, it is most 

likely because the vertices are not close enough. You can either move one of the vertices closer or increase the 

strength of the merge by removing one of the zeroes. You can either do this in the options box, which I do not 

recommend since you will probably have to change it back, or in the viewport, which resets each time you merge. 

 

Remember: This tool is only used for spotting unmerged vertices, not merging them. You have to switch back to Vertex 

mode and exit the tool once you have located the problem to fix it. 

Running Mesh Cleanup 

• When cleaning your models, you will be using Mesh Cleanup. 

• In Mesh Cleanup Options, you want to make sure to mark Select matching polygons (shows the issues), check 

Faces with more than 4 sides (shows n-gons), Non-planar faces (shows faces that are not fully flat), Lamina faces 

(shows faces on top of each other), and Non-manifold geometry (shows areas that cannot be unfolded flatly, this 

will be a problem when UVing). Then hit Cleanup (closes the menu after) or Apply (menu stays open after).  

 



• I have found that sometimes Maya will say that a vertex is non-manifold, even though you cannot find a reason 

for this or seem to fix it. I have found that a way to fix this, when other attempts do not work, is to delete the faces 

around the trouble vertex and then Bridge or Append them back in.  

• This is what a Non-manifold vertex looks like when you run Mesh Cleanup.  

    
• Sometimes you can get away with doing one face at a time, but most of the time you have to delete all the faces 

connected to the vertex. So, for this example, you have to delete these faces: 

       
• To fill in these gaps you can do a variety of things. I like to start by extruding an edge so that I can Bridge in the 

rest. To extrude an edge, select the edge, hit Ctrl + E, and then drag away. If you combine this with holding down 

the V key, you can snap the extruded edge to a relative point.  

    



• Once you have done this you want to remember to merge the vertices. These vertices are not merged, and this will 

cause problems later.  

 
• Now, you can Bridge. To Bridge select two edges opposite of each other. Then either go to Edit Mesh > Bridge or 

hit the Bridge button on the Shelf.  

      

• You can also use Append to Polygon under Mesh Tools. To use this, select an edge and then an opposite edge. 

This is what it looks like when it has been filled in. If you clicked the wrong edge and want to go back a step, ctrl 

+ Z will not work, but you can hit Delete to go back a step. Once you are done hit Enter to set the face. 

Remember: Purple indicates an unattached edge, so make sure your face is attached on all sides. 

     



• I prefer to use Bridge, which is typically faster. But Bridge will not always work so this is a good alternative, such 

as if you are filling in a triangle.  

• With it all filled in, you can run Mesh Cleanup again… 

 
• No problems.  

• Remember: You have to be in Object Mode with the object selected for it to run Mesh Cleanup on the object.  

Move UVs by 1 UDIM  

• To help reduce render times, we placed certain objects in the same Shading Group. For instance, we placed each 

of our Tombs in a single Shading Group. To do this, each of the ten Tombs needed to be placed on a different 

UDIM.  

• Each large square in the UV Editor is a UDIM, there are ten in each row. 

        

• First, lay out your finished UVs on UDIM one. 

 

• Then be in UV Shell Mode. Select the shells, and switch to the Move Tool (W). 

 

 

 

 

 



 

• Once you have adjusted the Move value, with your shells selected, you can use the arrow keys to move the shells 

left, right, up or down, UDIM by UDIM. So, this particular Tomb, Tomb 09 goes on UDIM nine. All I had to do 

was hit the right arrow key eight times and it was in the right UDIM. 

 

• Some other useful shortcuts to remember when you are UVing are Shift + X to Cut, Shift + S to Sew, and Ctrl + 

U to unfold. 

• Hopefully, this document has helped you better understand the process behind getting a clean model. It might not 

seem as important at the beginning, but this will help you down the line. Clean models mean clean UVs which 

textures require, not to mention, it will ensure no extra time is added to your renders because of unnecessary 

calculations.  

 

• Then in the UV Toolkit, under Transform, go 

to the Move drop down and change the value 

to 1.0000. This will allow you to move all the 

shells over UDIM by UDIM using the arrow 

keys.  

• Note: You might have to move the shells with 

the Move Tool arrows first for it to register. 

Just make sure to undo it back to the center of 

the UDIM before moving with the arrow keys 

so you do not lose your shell placing. 


